• Announcements

    • turbofandude

      Proper Problem Reporting for the TFDi Design 717   07/09/2017

      Folks, As the user count is increasing, it is becoming more of a task for us to stay on top of problem reports. We are also receiving an increasing amount of incomplete reports that we are unable to follow up on (which frustrates everyone, us included). On that note, we are going to be enforcing a stricter formal problem reporting system. There are a few main points that need to be addressed. ALL problem reports must be submitted via the Bugs and Suggestions system. Open discussion on the forums is fine, but our team simply cannot respond to every single comment (especially when the majority of doing so is asking for information the Bugs and Suggestions system already asks for). Incomplete reports will be ignored. This means reports like "my FPS is bad" will not be given weight. This isn't because we don't care. It is because a report like that does absolutely nothing for anyone - we can't fix it based on that. Please include EVERYTHING you can possibly think of regarding the problem and take as many steps as you can to isolate it. Prepar3D v4, despite what you have heard, can still be unstable. Yes, it is definitely possible to fly flights without issues. But it is still relatively new, as are most of the addons available for it. Please refrain from attacking us or other developers because of this. We have already had one scenario where a 717 CTD was resolved by an update to Prepar3D itself. This is likely not the only time that will be the case. You are still free to report the crashes, as it may help whoever the developers of the faulting code are solve the issue. Duplicate reports will be deleted/merged. For the sake of sanity for us trying to prioritize and evaluate issues, if we discover multiple reports of the same thing, we may merge/delete the duplicates. We strongly encourage you to search and see if your problem has been reported before. Thank you all in advance. This may seem overbearing, but this is the only way we are going to be able to stay on top and continue heading in the direction we, and the community, want.
kymh

P3Dv4 - Error Connecting to Database

Recommended Posts

Thanks for getting out the P3Dv4 update.

 

I'm getting framerates of 16 to 21 fps where other craft are giving me about 60fps but I'm sure it's just early days

 

Unfortunately I have errors immediately after running:-

The first being "Error Connecting to Database".

After that I get "Session is not connected" which keeps on popping up about every 20 seconds in sets of four (have to click OK four times.

 

Regards Kym H

 

bummer1.JPG

bummer2.JPG

Share this post


Link to post
Share on other sites
17 minutes ago, Deceiver said:

I found opening the Addon Manager fixed the session error.

No solution for the texture error though - getting that here too.

Disregard. Still getting this error when trying to enter any nav data to the FMC

Share this post


Link to post
Share on other sites
31 minutes ago, Deevilius said:

What helped me was loading the aircraft --> errors appear. then load the aircraft again, and everthing was fine.

Loading nav data into the FMC works fine too?

EDIT: Can't get this to fix my problems

Edited by Deceiver

Share this post


Link to post
Share on other sites
9 minutes ago, Deevilius said:

i also installed everything from C:\Program Files (x86)\TFDi Design\Addon Manager\Redistributables

i dont know if this helped too.

This may be the key - it appears as though it's trying to access the navdata and not being able to. The navdata is in MS Access format, so this could be why.

Just installed AccessDatabaseEngine_X64, so going to give it a whirl.

Share this post


Link to post
Share on other sites

Okay, here's the fix dudes.. navigate to your x:\Program Files (x86)\TFDi Design\Addon Manager\Redistributables directory, run the installer for AccessDatabaseEngine_X64
Restart your sim, load the aircraft, and life should be good.

Thanks to Deevilius for the tip.

  • Like 1

Share this post


Link to post
Share on other sites

But that would not work if you have Microsoft 32 bit office version installed, it is then not possible to run the 64bit Access Engine, any solution?

 

Best regards and thanks to the team for the quick Version 4 update.

Edited by vickers viking

Share this post


Link to post
Share on other sites
4 hours ago, Deceiver said:

Okay, here's the fix dudes.. navigate to your x:\Program Files (x86)\TFDi Design\Addon Manager\Redistributables directory, run the installer for AccessDatabaseEngine_X64
Restart your sim, load the aircraft, and life should be good.

Thanks to Deevilius for the tip.

That is not a solution when you have already installed office 32 bit ;-)

Share this post


Link to post
Share on other sites

Wow glad Im not only one getting that annoying Session Error too. Also in FMC when I try to put in to  and from airport example KMCO/KCLT it says not in database everytime. 

Share this post


Link to post
Share on other sites
6 minutes ago, awf said:

That is not a solution when you have already installed office 32 bit ;-)

solved :-) in case of office 32 bit ;)

Chnage

How to install 64-bit Microsoft Database Drivers alongside 32-bit Microsoft Office

Issue:

You are trying to install the 64-bit Access Database Engine on your machine that is running 32-bit Microsoft Office (2007, 2010, or 2013) and you are getting an error message:

"You cannot install the 64-bit version of Microsoft Access Database Engine 2010 because you currently have 32-bit products installed..." (AccessDatabaseEngine_X64.exe)

User-added image

Causes:

Microsoft does not support the side-by-side installation of 32- and 64-bit Microsoft Office or their dependent components. 

Solution:

WRITTEN INSTRUCTIONS:

Workaround to install the 64-bit Access Database Engine 2010 on a computer with 32-bit Microsoft Office 2007, 2010, or 2013:


Before you begin, open the Registry Editory (type "regedit" in the Windows search box under the Start menu and select regedit.exe) and check the following registry key for the value "mso.dll" is NOT present in: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths" 

This registry key value would be present if Microsoft Office 64-bit was installed on the computer, in which case you should be able to install the 64-bit Access Database Engine without using this workaround.

Workaround:

1. Open the Command Prompt by typing "cmd" in the Windows search box under the Start menu and selecting cmd.exe
 
2. Type the file path and file name of the 64-bit AccessDatabaseEngine_X64.exe install file, followed by a space and "/passive" (this runs the installation without showing any error messages). 

For example:
User-added image

3. Open the Registry Editor by typing "regedit" in the Windows search box under the Start menu and selecting regedit.exe
 
4. Delete or rename the "mso.dll" registry value in the following registry key: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths" 

User-added image

NOTES:

  • If you do not delete the "mso.dll" registry value, you will get a "Reconfiguring" message every time you open up an Office application.

Share this post


Link to post
Share on other sites
19 minutes ago, awf said:

solved :-) in case of office 32 bit ;)

Chnage

How to install 64-bit Microsoft Database Drivers alongside 32-bit Microsoft Office

Issue:

You are trying to install the 64-bit Access Database Engine on your machine that is running 32-bit Microsoft Office (2007, 2010, or 2013) and you are getting an error message:

"You cannot install the 64-bit version of Microsoft Access Database Engine 2010 because you currently have 32-bit products installed..." (AccessDatabaseEngine_X64.exe)

User-added image

Causes:

Microsoft does not support the side-by-side installation of 32- and 64-bit Microsoft Office or their dependent components. 

Solution:

WRITTEN INSTRUCTIONS:

Workaround to install the 64-bit Access Database Engine 2010 on a computer with 32-bit Microsoft Office 2007, 2010, or 2013:


Before you begin, open the Registry Editory (type "regedit" in the Windows search box under the Start menu and select regedit.exe) and check the following registry key for the value "mso.dll" is NOT present in: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths" 

This registry key value would be present if Microsoft Office 64-bit was installed on the computer, in which case you should be able to install the 64-bit Access Database Engine without using this workaround.

Workaround:

1. Open the Command Prompt by typing "cmd" in the Windows search box under the Start menu and selecting cmd.exe
 
2. Type the file path and file name of the 64-bit AccessDatabaseEngine_X64.exe install file, followed by a space and "/passive" (this runs the installation without showing any error messages). 

For example:
User-added image

3. Open the Registry Editor by typing "regedit" in the Windows search box under the Start menu and selecting regedit.exe
 
4. Delete or rename the "mso.dll" registry value in the following registry key: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths" 

User-added image

NOTES:

  • If you do not delete the "mso.dll" registry value, you will get a "Reconfiguring" message every time you open up an Office application.

Thanks gonna try this. 

EDIT :  So this fixed the Database issue

Edited by jscarano

Share this post


Link to post
Share on other sites

Talking about the 717 perfomance on P3DV4

Result: Awful, comparing to V3 and other heavy aircraft 

In V3 is Good, but I was hoping improvements at V4

Share this post


Link to post
Share on other sites

Sorry, just downloaded the latest update, unstillaled and installed Version 4 and still have the same problems and two new errors, too:

 

1)unable to load odbcj32.dll

2) Error connecting to database

SQL_HANDLE_ENV(IM004)

 

Best regarrds

Share this post


Link to post
Share on other sites
32 minutes ago, horstling said:

After installing the latest Addon-Manager and The Aircraft in the pronounced Folders, everything works fine!!

Same for me :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now