• Announcements

    • turbofandude

      Proper Problem Reporting for the TFDi Design 717   07/09/2017

      Folks, As the user count is increasing, it is becoming more of a task for us to stay on top of problem reports. We are also receiving an increasing amount of incomplete reports that we are unable to follow up on (which frustrates everyone, us included). On that note, we are going to be enforcing a stricter formal problem reporting system. There are a few main points that need to be addressed. ALL problem reports must be submitted via the Bugs and Suggestions system. Open discussion on the forums is fine, but our team simply cannot respond to every single comment (especially when the majority of doing so is asking for information the Bugs and Suggestions system already asks for). Incomplete reports will be ignored. This means reports like "my FPS is bad" will not be given weight. This isn't because we don't care. It is because a report like that does absolutely nothing for anyone - we can't fix it based on that. Please include EVERYTHING you can possibly think of regarding the problem and take as many steps as you can to isolate it. Prepar3D v4, despite what you have heard, can still be unstable. Yes, it is definitely possible to fly flights without issues. But it is still relatively new, as are most of the addons available for it. Please refrain from attacking us or other developers because of this. We have already had one scenario where a 717 CTD was resolved by an update to Prepar3D itself. This is likely not the only time that will be the case. You are still free to report the crashes, as it may help whoever the developers of the faulting code are solve the issue. Duplicate reports will be deleted/merged. For the sake of sanity for us trying to prioritize and evaluate issues, if we discover multiple reports of the same thing, we may merge/delete the duplicates. We strongly encourage you to search and see if your problem has been reported before. Thank you all in advance. This may seem overbearing, but this is the only way we are going to be able to stay on top and continue heading in the direction we, and the community, want.
kymh

P3Dv4 - Error Connecting to Database

Recommended Posts

Hello,

I also have a problem with the database connection but it seems it is not the same. I tried the solutions above including reinstall and always the same messages when loading the aircraft:

- ODBC driver for Microsoft Access installation problem : Unable to load odbcji32.dll : OK

- SOCI ODBC Error : Error Connecting to database: [Microsoft][Gestionnaire de pilote ODBC] Echec SQLAllocHandle du pilote sur SQL_HANDLE_ENV (IM004)

I have MS Office 2013 32bits French installed and develop my own VB6 programs using ODBC MSAccess.

What can I do? Strange that a 32 bit dll is loading with P3Dv4? I hope my ODBC32 configuration for my own programs is not the problem.

Skip.

EDIT!!!! I also have Fsx installed with another Windows user and TFDI 717 on it. So 32 and 64 bit versions of the same product on my machine.

Edited by Skipy
Last news

Share this post


Link to post
Share on other sites

I first got tons of error messages when trying to install the 717 in P3D v4. After uninstalling the plane from P3D v3 and re-installing the addon manager, everything seemed to work fine. However, when I start the plane in P3D v4, I get several pop-up windows stating "Session is not connected". I can click it away, but when I try to enter dperature and destination on F-PLN INIT 1/3, I get the same window, and the CDU states "not in database".

Peter

Share this post


Link to post
Share on other sites

I just downloaded the new Addon Manager and uninstalled & installed but the error remains exactly as in my first post.

I have MSOffice 2007 installed.

 

Thanks for your efforts thus far.

Share this post


Link to post
Share on other sites
32 minutes ago, kymh said:

I just downloaded the new Addon Manager and uninstalled & installed but the error remains exactly as in my first post.

I have MSOffice 2007 installed.

 

Thanks for your efforts thus far.

Follow my solution I posted that will solve the issue in case of 32bit office installed ;-)

Edited by awf

Share this post


Link to post
Share on other sites

Thanks AWF,

There is no problem installing the 64-bit Access Database Engine 2010 and the "mso.dll" registry value entry does not exist.

On the latest attempt, I uninstalled from P3Dv4 as well as P3Dv3 this time and the database error is no longer evident.

The scenery read error however still exists.

1.JPG.3445e56224ad5f677e8550a3e4109d6e.JPG

I've only loaded the aircraft and haven't yet had a chance to try a flight but haven't yet seen the "Session is not connected" error.

Copying "EffectsAtlas.dds" into "H:\Prepar3D v4 Addons\FSDreamteam\Addon Manager\Simobjects\Airplanes\TFDi_Design_717\Effects\Texture" of course removed the error as this is what/where it is looking for this file.

I can't find a .cfg file that explains the above path.

So the difference for me this time was to not only uninstall the P34v4 copy but also the P3Dv3 copy.

 

Edited by kymh
typos

Share this post


Link to post
Share on other sites
1 hour ago, kymh said:

Thanks AWF,

There is no problem installing the 64-bit Access Database Engine 2010 and the "mso.dll" registry value entry does not exist.

On the latest attempt, I uninstalled from P3Dv4 as well as P3Dv3 this time and the database error is no longer evident.

The scenery read error however still exists.

1.JPG.3445e56224ad5f677e8550a3e4109d6e.JPG

I've only loaded the aircraft and haven't yet had a chance to try a flight but haven't yet seen the "Session is not connected" error.

Copying "EffectsAtlas.dds" into "H:\Prepar3D v4 Addons\FSDreamteam\Addon Manager\Simobjects\Airplanes\TFDi_Design_717\Effects\Texture" of course removed the error as this is what/where it is looking for this file.

I can't find a .cfg file that explains the above path.

So the difference for me this time was to not only uninstall the P34v4 copy but also the P3Dv3 copy.

 

We're looking into this.

Share this post


Link to post
Share on other sites

Hi,

with the latest update ( 6th f June, 8 am Greenwich time 1.1.5.0) I have still the same Problems, nothing has changed. Could it be that we have a Problem with diffrent languages ( Windows and Office), I use the german Versions?

 

Best regards

Share this post


Link to post
Share on other sites

Hello,

I just installed the new Addon Manager and launch a new install on P3DV4. The Microsoft Access Database Engine has been installed properly at this occasion. But I have still the same errors when loading the aircraft:

- ODBC driver for Microsoft Access installation problem : Unable to load odbcji32.dll : OK

- SOCI ODBC Error : Error Connecting to database: [Microsoft][Gestionnaire de pilote ODBC] Echec SQLAllocHandle du pilote sur SQL_HANDLE_ENV (IM004)

And still the same question about this 32bits DLL and the possible interaction with my own ODBC settings to connect access databases.

Skip.

Share this post


Link to post
Share on other sites

I GOT IT!!! And I think this will help Vickers as well.

5 hours ago, vickers viking said:

Hi,

with the latest update ( 6th f June, 8 am Greenwich time 1.1.5.0) I have still the same Problems, nothing has changed. Could it be that we have a Problem with diffrent languages ( Windows and Office), I use the german Versions?

 

Best regards

I uninstall the 64bits English Microsoft Access Database engine 2010 that was installed by the addon manager. Then I downloaded from Microsoft site the same package but in French and it's OK now.

Just have to perform a first flight between Zurich and Luxembourd (both addons P3Dv4 compatible in Europe).

Skip.

Share this post


Link to post
Share on other sites

The next issue. The 717 is installed in v4 and v3, but the addon manager does not show it. If I press the install button for v4, an insatlltions starts and show me "installed" - but no version. After restart of the addon manager, I see the "install"-button again. Two shots:

 

v4_install.JPG

v4_uninstall.JPG

Share this post


Link to post
Share on other sites

I can add to this also. I've just done a flight in V4:$

Do I need to install again?

It is V1.0.8.2  in V4 also I checked in FMC

installer1_zpsiorjfcxm.jpg

Edited by Alpha117

Share this post


Link to post
Share on other sites

Well, I went for it and pressed install........ooops, the installer tries to install more than one item at a time(SImmconnect and Access DB engine), so SimConnect installation falls over.

Installed  'MicrosoftVisual C++2015 Redistributable (x64)  14.0.24215.  Well not sure what that achieved, still the same as my screenshot above

 

Edited by Alpha117

Share this post


Link to post
Share on other sites

yes i have errors since release for v4 , same as above and when v4 loads i get a scenery and texture error. When i try to install scenery with a v4 installer it does not install, there is another addon manager from fsdt and i think its conflicting with it, happen after i installed tfdidesignv4

Share this post


Link to post
Share on other sites
21 hours ago, turbofandude said:

@Skipy @qqwertzde Can you both try clicking "Uninstall", then "Install" on the P3Dv4 version in the Addon Manager again? It should fix this.

That fixed it indeed.

Thanks Collin,

Peter

Share this post


Link to post
Share on other sites

Hang in there Vickers,

I know it's frustrating but we should understand that the team can either be fixing things or spending their day in the forum.
The occasional answers are great but I'd rather think they're slogging away with fixes than patting us on the heads in here.

They are obviously working on it.

My problem persisted until I uninstalled both the P3D3 and P3D4 versions of the 717 and that just left me with the texture error message which didn't stop me from flying the 717 at all.

To get rid of the texture error until the boys have fixed it, I copied "EffectsAtlas.dds" from h:\Prepar3D v4\SimObjects\Airplanes\TFDi_Design_717\Effects\Texture into the folder named when I got the Scenery read error so it could find what it was looking for.

In my case it was  "h:\Prepar3D v4 Addons\FSDreamteam\Addon Manager\Simobjects\Airplanes\TFDi_Design_717\Effects\Texture"
I see that for some others, it's looking in other places which makes me ask is this a TFDi problem or a P3D problem?
Either way, when the problems vary from user to user, it's got to make it harder to figure it out and fix.

If LM have been developing 64bit for eight years (as I've heard), then we can hardly expect any developer to be instantly on top of the exact workings of the new sim.

Regardless, hang on in there as I can assure you, when you get to fly this bird in prepar3Dv4 without the threat of OOMs, it's a damn pleasure and just beautiful to fly.
It certainly has me questioning my urgent needs for even a A320,A330,A380, 777 or 787 etc.

At least TFDi have given us the chance to fly the3 717-200in Prepar3Dv4 so shortly after its release date.
I've got dozens of other payware aircraft who obviously are going to keep us waiting for a long time.Good luck.

 

Regards Kym H

 

 

Edited by kymh
  • Like 1

Share this post


Link to post
Share on other sites

I just installed the latest update 1.0.8.2.

In P3Dv4 I get no database errors.

I still get the Scenery Read Error but now, it first happens when I click either "Ready to Fly" or "Ready To Start" after opening the tablet.

This will happen regardless of whether or not I start with the 717 or another aircraft.

v1082.JPG.20f6ec3919246455da25866af009d765.JPG

Copying "EffectsAtlas.dds" to the folder above still removes the error for me of course.

 

Thanks for your hard work so far guys!

Regards Kym H

  • Like 2

Share this post


Link to post
Share on other sites
20 hours ago, vickers viking said:

Sorry, I give up for a while. Got the feeling that the Company is not able to deliver any solution for the problem right now, what a shame.

Best regards   

Vickers, this problem has existed for literally 48 hours for us. We've already spent several hours debugging it and have arrived at several possible solutions, we're just weighing our which one is best. Please give us some time.

 

Everyone else, I believe we'll have a fix today.

Share this post


Link to post
Share on other sites

Hi turbofandude,

 

i am really glad that you try to enable to use the 717 so early for prepar3d Version 4. It is no problem if you need more time to find a final solution. I will try from time to time to update the addon manager and will see what happens.

Best regards

vickers viking 

Share this post


Link to post
Share on other sites

Hi,

I receive the ODBC error as shown above when starting the TFDi 717 under P3D V4 (...Unable to load odbcji32.dll : OK...).

What should I do?

Thanks,

Fabio

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now