• Announcements

    • turbofandude

      Proper Problem Reporting for the TFDi Design 717   07/09/2017

      Folks, As the user count is increasing, it is becoming more of a task for us to stay on top of problem reports. We are also receiving an increasing amount of incomplete reports that we are unable to follow up on (which frustrates everyone, us included). On that note, we are going to be enforcing a stricter formal problem reporting system. There are a few main points that need to be addressed. ALL problem reports must be submitted via the Bugs and Suggestions system. Open discussion on the forums is fine, but our team simply cannot respond to every single comment (especially when the majority of doing so is asking for information the Bugs and Suggestions system already asks for). Incomplete reports will be ignored. This means reports like "my FPS is bad" will not be given weight. This isn't because we don't care. It is because a report like that does absolutely nothing for anyone - we can't fix it based on that. Please include EVERYTHING you can possibly think of regarding the problem and take as many steps as you can to isolate it. Prepar3D v4, despite what you have heard, can still be unstable. Yes, it is definitely possible to fly flights without issues. But it is still relatively new, as are most of the addons available for it. Please refrain from attacking us or other developers because of this. We have already had one scenario where a 717 CTD was resolved by an update to Prepar3D itself. This is likely not the only time that will be the case. You are still free to report the crashes, as it may help whoever the developers of the faulting code are solve the issue. Duplicate reports will be deleted/merged. For the sake of sanity for us trying to prioritize and evaluate issues, if we discover multiple reports of the same thing, we may merge/delete the duplicates. We strongly encourage you to search and see if your problem has been reported before. Thank you all in advance. This may seem overbearing, but this is the only way we are going to be able to stay on top and continue heading in the direction we, and the community, want.
kpan24

P3Dv4 CTD when switching views

Recommended Posts

I've only had the 717 for two days and P3Dv4 for a week, but both yesterday and today P3D crashed when switching view from outside view back to inside view.  And it doesn't happen until the view has been switched several times.  Also, frame rates are all over the place.  Anywhere from a low of 8 to high of 60 in just a few minutes.

Share this post


Link to post
Share on other sites

I had the same 2 times today. For frame rates I seem to be having better luck with hardware rendering off. 

Share this post


Link to post
Share on other sites

I use Windows Defender only.  Here is an event log.

Faulting application name: Prepar3D.exe, version: 4.0.23.21468, time stamp: 0x59279be2
Faulting module name: KERNELBASE.dll, version: 10.0.15063.296, time stamp: 0xa0527b0c
Exception code: 0xc000041d
Fault offset: 0x0000000000069e08
Faulting process id: 0x256c
Faulting application start time: 0x01d2de41e199ab3f
Faulting application path: G:\Prepar3D v4\Prepar3D.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 52402552-3b47-4bef-a4d4-f91f1416172f
Faulting package full name: 
Faulting package-relative application ID: 

Share this post


Link to post
Share on other sites

I'm having this CTD too when I switch between views on the 717 and the event viewer attributed it to menus.dll.  Similar symptoms as this: http://www.prepar3d.com/forum/viewtopic.php?t=122934.  I'm not sure if it's the 717 or something else, but I deleted my cameras.cfg last night and was finally able to finish a short flight.  

That may point to Chaseplane, since it edits cameras.cfg - I'm wondering if those with this problem are all using Chaseplane and if deleting cameras.cfg helps.

Share this post


Link to post
Share on other sites

I do not believe this bug is in the 717, especially since it's apparent primarily in P3Dv4. I've been able to grab a minidump and it did not show any 717 code up to the crash, either. We'll keep looking.

Share this post


Link to post
Share on other sites

From what I've noticed, this happens to me if I mess around a change settings within P3D, If I don't change any settings, and don't go to settings, it works fine. I was able to complete 2 3+ hours flights yesterday.

Share this post


Link to post
Share on other sites

I had this also but I noticed that it only happens when I click on the 'cockpit' view only... Not in the virtual cockpit 

Share this post


Link to post
Share on other sites
On 07/06/2017 at 0:42 PM, kpan24 said:

I've only had the 717 for two days and P3Dv4 for a week, but both yesterday and today P3D crashed when switching view from outside view back to inside view.  And it doesn't happen until the view has been switched several times. 

Hi. I can confirm I'm experiencing this exact same issue (I'm switching views using ChasePlane) in P3Dv4. By comparison, I have spent many hours in the PMDG 747 and not encountered this problem. 

Share this post


Link to post
Share on other sites

Unfortunate how things work out here. I really don't think it is Prepar3D v4. In fact, for me it is the most stable Sim so far. I can fly longhauls and change the views like I want and nothing ever happens (Chaseplane user). All the PMDG aircraft I use perform very very stable. No CTD since P3D v4.

Today I was on my way to buy the TFDI 717 and watched a livestream. After he switched to the cockpit, the sim crashed, so I decided to have a look here. It seems a lot of people having trouble with this issue. 

So what to do now? LM confirmed some instability here? Because from all what I read so far, it really seems to be a problem with the 717. 

Share this post


Link to post
Share on other sites

I'm using ezdok camera and also have had this crash twice when switching views. Performance hasn't been a problem. But I have yet to finish a flight.

Share this post


Link to post
Share on other sites
14 hours ago, Streichholz said:

Unfortunate how things work out here. I really don't think it is Prepar3D v4. In fact, for me it is the most stable Sim so far. I can fly longhauls and change the views like I want and nothing ever happens (Chaseplane user). All the PMDG aircraft I use perform very very stable. No CTD since P3D v4.

Today I was on my way to buy the TFDI 717 and watched a livestream. After he switched to the cockpit, the sim crashed, so I decided to have a look here. It seems a lot of people having trouble with this issue. 

So what to do now? LM confirmed some instability here? Because from all what I read so far, it really seems to be a problem with the 717. 

Well, we've had the sim crash all by itself (no addons). We've seen crash reports (even here in our own forums) with other addon planes. Trust me - that responsible is not an attempt to sidestep responsibility. There are definitely things we've fixed and still need to fix - but these crashes suddenly appeared in V4 for us and NOTHING at all points them to us. The things that are crashing are not even used by our code most of the time and there are no minidumps or anything created. Debugging those sorts of things is next to impossible.

Share this post


Link to post
Share on other sites
1 hour ago, jasonpc said:

I'm using ezdok camera and also have had this crash twice when switching views. Performance hasn't been a problem. But I have yet to finish a flight.

Are there ANY minidumps? Any event viewer logs? Anything?

Share this post


Link to post
Share on other sites

Only thing is in event viewer

Fault bucket , type 0
Event Name: AppHangTransient
Response: Not available
Cab Id: 0
Problem signature:
P1: Prepar3D.exe
P2: 4.0.23.21468
P3: 59279be2
P4: unknown
P5: unknown
P6: unknown
P7: unknown
P8:
P9:
P10:
Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WEREB2B.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WEREB2B.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WEREB3C.tmp.txt
These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 93abc11d-d46a-4934-9bb5-1d92ce149bcb
Report Status: 2049
Hashed bucket:

I checked C:\ProgramData\Microsoft\Windows\WER\Temp\ and I didn't see any files though.

Share this post


Link to post
Share on other sites

That doesn't looks like TFDi 717 fault

Obey to Collin, It's just the unstable LM simulator Prepar3D V4

 

Share this post


Link to post
Share on other sites

What I don't get here, I have done several flights with PMDG without any issues at all in v4. I know some guys doing flights with the PMDG 747 SBGR - CYVR - EDDM - KLAX - EDDM without restarting the Sim (stresstest) and have 0 CTDs or other problems (I would know it if they have, because I have to give support for them). Even PMDG stated P3D v4 "Prepar3D v4 is stable.  It is probably one of the more stable simulation releases we have seen in years. "

https://www.avsim.com/forums/topic/512651-14jun17-how-not-to-mess-up-a-perfectly-good-prepar3d-v4-installation/ (source)

I mean, they have experience here for about 25 years? How will your statement "P3D v4 is an unstable platform" and their statement "P3D v4 is stable" come together? 

Also I am in flightsimulation like more than 20 years now and believe me, I have seen a lot. And from my experience so far, v4 is very stable.

Don't get me wrong here. I followed you guys since you released SmartCARS and I believe, the 717 is a wonderfull aircraft and that's why I bought it last night to support you. You have a lot of potential!

But I will do some testflights with the 717 and see for myself. 

Share this post


Link to post
Share on other sites

I have the other PMDG aircraft and have never had a CTD in p3dv4. My other experiences with p3dv4 have seemed to suggest the sim is extremely stable. This just started with the 717 on my very first flight. It also happened on my second flight.

I made a successful third flight but I barely ever switched views at all. I also switched to hardware rendering for the displays.

Not to be discouraging, just want to help squash this issue. I love this plane. Without the B737 or A319/320 I have been dying to fly a smaller commercial jet.

 

 

 

Edited by jasonpc

Share this post


Link to post
Share on other sites

So my experience so far.

It is an amazing aircraft!!! You guys rock, really. It is so much fun to fly this aircraft! 

So far, I have the same problem with THIS aircraft, like 3/4 of the people here. Switching the views CAN cause a CTD, but it doesnt't have to. I managed one flight without any issue. Sometimes to the outside, sometimes to the inside (random).

I have no Idea what exactly causes this, but it really is something during the view-switch and ONLY with the 717 so far. Like I said, no CTD whatsoever so far with any other aircraft. This includes the A2A C172, Piper Comanche, PMDG 777 and PMDG 747. 

I use: Chaseplane. Maybe something together with this aircraft and ChasePlane causes this? Event viewer says "menus.dll", but I'm not sure if this will help you.

 

 

Share this post


Link to post
Share on other sites
13 hours ago, Streichholz said:

So my experience so far.

It is an amazing aircraft!!! You guys rock, really. It is so much fun to fly this aircraft! 

So far, I have the same problem with THIS aircraft, like 3/4 of the people here. Switching the views CAN cause a CTD, but it doesnt't have to. I managed one flight without any issue. Sometimes to the outside, sometimes to the inside (random).

I have no Idea what exactly causes this, but it really is something during the view-switch and ONLY with the 717 so far. Like I said, no CTD whatsoever so far with any other aircraft. This includes the A2A C172, Piper Comanche, PMDG 777 and PMDG 747. 

I use: Chaseplane. Maybe something together with this aircraft and ChasePlane causes this? Event viewer says "menus.dll", but I'm not sure if this will help you.

 

 

I've had exactly the same, but I'm not using Chase Plane.  Only started when flying at dusk, but I'll keep experimenting.

Menu.dll is shown in the event viewer.  So far the crashes (3 at the moment) happen when moving from outside view back to VC.

 

Share this post


Link to post
Share on other sites

I've encountered the same issue with CTD 80-90% of the time. I've only completed 2 flights.

I use Chase Plane and my gut feling is that when you change from internal to external, then back again I get a CTD.

Hopefully we can see a resolution to this as I so want to fly this plane more and more ;) 

 

Share this post


Link to post
Share on other sites
1 hour ago, Dvotee said:

I've encountered the same issue with CTD 80-90% of the time. I've only completed 2 flights.

I use Chase Plane and my gut feling is that when you change from internal to external, then back again I get a CTD.

Hopefully we can see a resolution to this as I so want to fly this plane more and more ;) 

 

You will have fixed this issue soon, It seems that 1.0.9.1 is taking a lot of work and time to be release

Cheers!

Santiago

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now