N752SK

Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral
  1. I understand the aircraft is currently being tested for V5. Ive downloaded the addon manager per my purchase email, and I only have the option to install into FSX, FSX:SE, P#D V2/3/4. I dont have any of these sims, I only have V5. Thank you