ProfessorMadman

P3D V4 CTD - no errors

Recommended Posts

I'm finding on a few occasions the 717 will crash the sim without errors and without generating debug reports.  I've now had 4 such crashes with P3D v4 but have also successfully completed other flights without crashes.  I've checked the event viewer and no errors are recorded around the time of the CTD.  P3D hangs for a few seconds, then I get the spinning blue circle of death and the sim crashes to desktop.

 

As per another topic I suspected it was down to switching views but this time it crashed in the VC when just trying to pan to the CDU.  Attaching a screenshot of the exact place it happened but I don't think that's relevant.

 

I'm running the 717 with Hardware Rendering off.

 

CTD.png

Edited by ProfessorMadman
Added hardware rendering info

Share this post


Link to post
Share on other sites
3 minutes ago, piperpilot said:

I have been flying the 717 in P3D V4 and had no problems at all so far this is turning out to be a beauty

Agreed!

Share this post


Link to post
Share on other sites

Thanks for your reports guys.  Just out of interest are any of you using the pop-out displays a lot?

I'll keep on flying and see if I get more CTD but I'll rule out the 717 for now then.  It's just strange that the 717 is the only aircraft I'm getting these crashes with in v4.  I have flown the 744 extensively in v4 and did a 16 hour flight in the 77L.  Zero crashes so that lead me to the conclusion I had.

Share this post


Link to post
Share on other sites

Just for reference, had another CTD in the 717 just now, no errors reported in the event viewer approaching KDEN on the TSHNR 2 arrival.  I was unfocused on the P3D window at the time and at cruise at FL350 (was posting on AVSIM) so I was not doing anything that could have triggered a CTD (like switching a view, panning, etc.).

Share this post


Link to post
Share on other sites
2 minutes ago, ProfessorMadman said:

Just for reference, had another CTD in the 717 just now, no errors reported in the event viewer approaching KDEN on the TSHNR 2 arrival.  I was unfocused on the P3D window at the time and at cruise at FL350 (was posting on AVSIM) so I was not doing anything that could have triggered a CTD (like switching a view, panning, etc.).

Roger! Same happened to me yesterday at LSGG Geneva

Wait for TFDi, There are at FlightSimCon 2017

Cheers

Santiago

Share this post


Link to post
Share on other sites

Santiago, yes I'm aware :) Joshua already informed me that they fixed the ATS speed issue I reported and the fix will be be available in the next build.  It is good to hear that I'm not the only one experiencing CTD with the 717 though. 

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, ProfessorMadman said:

Santiago, yes I'm aware :) Joshua already informed me that they fixed the ATS speed issue I reported and the fix will be be available in the next build.  It is good to hear that I'm not the only one experiencing CTD with the 717 though. 

Yeah! Good to hear about ATS issue :D

Share this post


Link to post
Share on other sites

Another journal entry to keep track of CTDs for me.  Just had another CTD without error at cruise, FL320 over Italy on route LICJ - LGIR.  Was idle in the sim at the time (not touching anything or doing anything).  The sim just froze, although sound kept playing.  After the visuals froze up I tried to switch to external and heard the external sounds but was still in the VC.  Then CTD without error.

I've now tried the flight that just crashed with hardware rendering on, still same outcome.

Share this post


Link to post
Share on other sites
3 hours ago, ProfessorMadman said:

Another journal entry to keep track of CTDs for me.  Just had another CTD without error at cruise, FL320 over Italy on route LICJ - LGIR.  Was idle in the sim at the time (not touching anything or doing anything).  The sim just froze, although sound kept playing.  After the visuals froze up I tried to switch to external and heard the external sounds but was still in the VC.  Then CTD without error.

I've now tried the flight that just crashed with hardware rendering on, still same outcome.

I had the same CTD like you between UBBG and LRCK. after reaching cruise altitude I had CTD. tried the same route 3 times. 2nd and 3th flight was during climb CTD. By the way terrian and wxr radars doesnt woks even i have peak mode on.    ??

Share this post


Link to post
Share on other sites

Same here CTD in v4 whilst in the cruise in the 717 flying down the east coast of America not even touching anything. P3D just died. Nothing in the windows event log.

  • Like 1

Share this post


Link to post
Share on other sites
On 13/06/2017 at 7:38 PM, turbofandude said:

P3Dv4 has been very unstable so far - we've been fighting a number of issues not present in other sims.

The only CTD's I've experienced were only if I right click on the "cockpit" option to change the view... With other add on when i do this I only have a full ahead view without panel but with the 717 it goes CTD....

Share this post


Link to post
Share on other sites
9 minutes ago, Seb77 said:

The only CTD's I've experienced were only if I right click on the "cockpit" option to change the view... With other add on when i do this I only have a full ahead view without panel but with the 717 it goes CTD....

Does it crash every time?

Share this post


Link to post
Share on other sites

Any chance you using chaseplane? if yes do you use experimental build? Regular build used to crash for me when changing cameras

Share this post


Link to post
Share on other sites

I am using Chase Plane too, I've had 4 CTDs of the 5 attempts I've made to fly the plane. I think it happens after i cycle too many views but I don't have much more data than that. The most recent two crashes did not yield any logs in event viewer. The first few times I the application crash log pointed to Prepar3d.exe and KernelBase.dll. I've also experienced an application hang CTD. The other two CTDs did not have any errors.

 

Share this post


Link to post
Share on other sites

I am getting CTD as well when I am pushing back and am in external view when I go to pan it just ctd without any warning other than not responding but no error msgs at all

Share this post


Link to post
Share on other sites
On 6/14/2017 at 5:38 AM, turbofandude said:

P3Dv4 has been very unstable so far - we've been fighting a number of issues not present in other sims.

Not sure why it is unstable. I have been flying V4 since the day it was released and have not had a problem with it other than when I load the 717. All my other aircraft are performing fine and I am getting FPS around the 100 mark in external view and 50 - 75 in virtual cockpit.

I personally would say it is not unstable and is the best sim ever released.

Share this post


Link to post
Share on other sites

Have flown 10 flights with actual version in P3Dv4 and haven't faced any issue...very stable. Using GSX without problems.

I'm running on a 6850K@4.4 16GB RAM GTX1070@2140 with tripple screens.

Edited by Mischa

Share this post


Link to post
Share on other sites

For me it crashes when changing views pretty much 4 out of 5 flights. I use p3dv4 and chaseplane. I had no crashes to date using other 747 & 777. So far only happens with 717. Usually when changing view from inside to outside or other way around. I see loading circle of death and Prepared stopped working message.

Pretty much grounds 717 for me until this CTD goes away.

Share this post


Link to post
Share on other sites

Seems to be a problem with Chaseplane itself. I do not own this program and never faced any problem as you described. Remove Chaseplane and try again. For me the 717 didn't run into any CTD. There some minor bugs to fix but there are no CTDs.

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.