Ilya_Plt

The Ole App Hang on Change Views is Back

Recommended Posts

Using .9 and EZdok.  Happened when I went from wing view back to cockpit.  Only happens with this plane.  Nothing in logs except the P3D hang.  

 

Share this post


Link to post
Share on other sites

Let's start by tracing back to what has changed in between the time you didnt had this issue till it resurface again. 
 

  • From what version (1.x.x.x to 1.x.x.x) was it ok?
  • Any changes made to the sim comparing the period before and after (Ie, any addons installed, cfg/settings tweak, windows/driver updates)?

Share this post


Link to post
Share on other sites

This is not a 717 "bug". We have managed to have some users recreate this crash with all of our code disabled - meaning that the simulator, all by itself, is crashing. I've also experienced a view switching crash that was resolved by restarting Active Sky/ChasePlane.

Share this post


Link to post
Share on other sites
1 hour ago, turbofandude said:

This is not a 717 "bug". We have managed to have some users recreate this crash with all of our code disabled - meaning that the simulator, all by itself, is crashing. I've also experienced a view switching crash that was resolved by restarting Active Sky/ChasePlane.

Interesting.  But why does this only happen to me with the 717 and not the CRJ or any of the PMDG planes?  So you're saying I should restart ASP4 when this happens?

Share this post


Link to post
Share on other sites
5 hours ago, Ilya_Plt said:

Interesting.  But why does this only happen to me with the 717 and not the CRJ or any of the PMDG planes?  So you're saying I should restart ASP4 when this happens?

Please help answer my questions.

14 hours ago, Joshua Che. said:

Let's start by tracing back to what has changed in between the time you didnt had this issue till it resurface again. 
 

  • From what version (1.x.x.x to 1.x.x.x) was it ok?
  • Any changes made to the sim comparing the period before and after (Ie, any addons installed, cfg/settings tweak, windows/driver updates)?

 

  • Like 1

Share this post


Link to post
Share on other sites

@Ilya_Plt I realized after that we may be talking about two different issues - the problem I'm discussing is a full on CTD, not just a hang. Please answer Joshua's questions and we will try to debug as best we can.

Share this post


Link to post
Share on other sites

Guys,

I really appreciate the help though this may be a tough nut to crack.  I think the issue has always been there but its not consistent.  It's quite possible that this may be caused by some incompatibility with EZdok.  If you guys get a chance, please test together with that app switching back and forth between internal and external view.

Also, not wanting to start a new topic about an inconsequential bug, the wipers were not stowing themselves after use using the park position.  

Thanks again.

Ilya

 

Share this post


Link to post
Share on other sites

I think it's an ezdok problem or perhaps a p3d problem. I randomly had it happen with the default F-22. It does seem to occur more often in the 717 for reasons unknown.

Share this post


Link to post
Share on other sites

I hate to say it TFDi, but there is SOMETHING that the 717 does that crashes the sim to desktop. The weird part is that the new Aerosoft CRJ  does it for me too.  It may not ONLY be the 717, but it IS the 717 - at least for me it is. Now, I wonder what they have in common?

I also fly the carenado premier a lot and no such behavior with that.  But there is some common feature that is used with the CRJ and 717 that crashes the sim.  Something that the Premier does NOT use. 

It almost seems like a video memory issue as I notice it almost always with a night / dusk flight and most all of my successful flights are day flights.  But it's almost like texture caching or something.  Both the CRJ and the 717 are very complex aircraft compared to the Premier.

Lastly, I am not using easy dock, not using not using active sky, not using chaseplane. 

just an idea,

Tyler Johnson

 

 

Share this post


Link to post
Share on other sites
1 hour ago, N825TJ said:

I hate to say it TFDi, but there is SOMETHING that the 717 does that crashes the sim to desktop. The weird part is that the new Aerosoft CRJ  does it for me too.  It may not ONLY be the 717, but it IS the 717 - at least for me it is. Now, I wonder what they have in common?

I also fly the carenado premier a lot and no such behavior with that.  But there is some common feature that is used with the CRJ and 717 that crashes the sim.  Something that the Premier does NOT use. 

It almost seems like a video memory issue as I notice it almost always with a night / dusk flight and most all of my successful flights are day flights.  But it's almost like texture caching or something.  Both the CRJ and the 717 are very complex aircraft compared to the Premier.

Lastly, I am not using easy dock, not using not using active sky, not using chaseplane. 

just an idea,

Tyler Johnson

 

 

What kind of Graphics Card are you using?

Share this post


Link to post
Share on other sites

I am using an MSI NVIDIA GTX 970 4GD5T OC.   So 4gb card, GTX.  It's a great card, but again, this issue only appears with the 717 and the CRJ.  I have probably 20 hours in the Premier1 with no crashes at all, just to draw the comparison.

I don't think it's the video card it's self, but maybe how it's utilized by the aircraft?

Just an idea...

Tyler

Share this post


Link to post
Share on other sites
6 hours ago, N825TJ said:

I am using an MSI NVIDIA GTX 970 4GD5T OC.   So 4gb card, GTX.  It's a great card, but again, this issue only appears with the 717 and the CRJ.  I have probably 20 hours in the Premier1 with no crashes at all, just to draw the comparison.

I don't think it's the video card it's self, but maybe how it's utilized by the aircraft?

Just an idea...

Tyler

I was trying to see how much VRAM you have and see if it may be an issue. What other add-ons do you have running at the same time?

Share this post


Link to post
Share on other sites

Joshua,

Not much of anything.. I use pretty much default scenery (or modified default scenery)..  I use FSXWX for weather (but this has been tested without fsxwx as well - with the same behavior).  I do have GSX installed, but have tested with it fully disabled.    Since the new lighting model came, it seems to be a bit better.  I actually had a flight that was at a twilight time and was able to use lights..  It was great! :)  

I am running a few flights tonight to see if it persists.  

Thanks for looking into it!  TFDi has been great!  You have a wonderful addon here!
Tyler

Share this post


Link to post
Share on other sites
2 hours ago, N825TJ said:

Joshua,

Not much of anything.. I use pretty much default scenery (or modified default scenery)..  I use FSXWX for weather (but this has been tested without fsxwx as well - with the same behavior).  I do have GSX installed, but have tested with it fully disabled.    Since the new lighting model came, it seems to be a bit better.  I actually had a flight that was at a twilight time and was able to use lights..  It was great! :)  

I am running a few flights tonight to see if it persists.  

Thanks for looking into it!  TFDi has been great!  You have a wonderful addon here!
Tyler

This is odd, to confirm, you are saying the app hang has happened more often before the new lighting?

Share this post


Link to post
Share on other sites

Yes.  The new lighting SEEMS to have helped, however, I've only flown two flights with the 717 in v4 since the new lighting has been rolled out. 

Not sure why.  But that's just so far. I'll get more opportunities to fly this week and will report back.  Also is there any way to make the plane a little less shiny in v4?

Tyler

Share this post


Link to post
Share on other sites

This just happened to me twice (I've never had this problem before with lots of flights in the 717) in a row while switching views with EZDOK. The system just stops responding and goes to a spinning cursor. I'm on the opt-in beta and running the .10 version. I thought perhaps it was the scenery causing it since I've not seen this before, but I just took off from the same location, same time, but in the PMDG 737 and all is working normally. Switching views, no issue.

Share this post


Link to post
Share on other sites

Great plane; very good immersion factor.  I have had a few ctd which seem to be view related.  fsuipc save feature makes me able to enjoy the plane and all of its many many positive sides, otherwise the risk of a ctd would be too much.  Love the plane though!!!

Share this post


Link to post
Share on other sites

I continue to gets these 'view change related' CTD's from time to time.  As with the poster above it is only with the 717 and the Aerosoft CRJ.

I haven't had an issue with any other aircraft, including A2A and PMDG.  I echo the fact that although it may not be a 717 bug, it's a P3d bug that is only exposed by certain aircraft.

Still enjoying the plane though!

 

Share this post


Link to post
Share on other sites

While its not a fix for whatever the problem is.....the way I deal with this view related CTD is to limit view switching during takeoff and climb.  Once I get to T/C I enable chaseplane cinematic mode.  Once I get to T/D I switch back to internal chaseplane views (I have hotkeys set for various internal views).  I have been able to successfully complete flights using this method.

Share this post


Link to post
Share on other sites
7 hours ago, hilkiah said:

While its not a fix for whatever the problem is.....the way I deal with this view related CTD is to limit view switching during takeoff and climb.  Once I get to T/C I enable chaseplane cinematic mode.  Once I get to T/D I switch back to internal chaseplane views (I have hotkeys set for various internal views).  I have been able to successfully complete flights using this method.

Completely agree.  Generally I don't get the CTD's when not switchhing views.  I have found that I can 'make it' crash if I want to though.  Yesterday I was short of time so didn't have time to finish my flight so thought I'd experiment - I haven't got ChasePlane so just cycles the default P3D external views a few times.

No problems at all while doing this, but as soon as I returned to the VC the sim crashed.  I also think that the longer you are 'outside' the more chance of a CTD when returning to VC.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.