• 0
vfrsouthbound

Display Frame Rate

Question

Since using P3DV4 i have terrible display frame rate mostly when departing and arriving. The Displays seem to lag very bad like between 2-5 fps on the displays. But the aircraft will be running just fine 20-30 FPS. I tried locking my frames at 30 and that seems to help a little. Also once I get near cruise it seems to smooth out a bit more. And clicking outside P3D, like multi-tasking, I can see the displays improve. Any ideas as to why this is happening? 

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 1

Unfortunately, I did a flight with the 717 today since a long time, and had massiv lags with the plane if the displays are on :(

Tried hardware rendering on and off, never had that issue before.

I did a fresh installation of my system before.

 

Is there any possible known issue?

Regards

Share this post


Link to post
Share on other sites
  • 0

Same problem here. When departing or landing extreme lag even P3D shows 25-30 FPS :(

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, fresH said:

Unfortunately, I did a flight with the 717 today since a long time, and had massiv lags with the plane if the displays are on :(

Tried hardware rendering on and off, never had that issue before.

I did a fresh installation of my system before.

 

Is there any possible known issue?

Regards

It could be possible that you have another addon that is using up more GPU usage. What sim are you using?

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, gamesyns said:

It could be possible that you have another addon that is using up more GPU usage. What sim are you using?

No, nothing. Only P3D is opened.

P3D v4.2 :) I made a BUg report too.

Share this post


Link to post
Share on other sites
  • 0
On 5/5/2018 at 5:31 PM, fresH said:

No, nothing. Only P3D is opened.

P3D v4.2 :) I made a BUg report too.

I was suggesting another addon in sim, do you have new scenery installed or any additional modules installed?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
20 hours ago, gamesyns said:

I was suggesting another addon in sim, do you have new scenery installed or any additional modules installed?

Nope nothing, that is the strange issue. Always the same :-S 

I made the flight from LOWW-LSZH (what I did a lot before the reinstallation).

I saw some performance issues in the past too but now its really heavy. 

 

I am available for any remote session or whatever you need :)

Edited by fresH

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, fresH said:

Nope nothing, that is the strange issue. Always the same :-S 

I made the flight from LOWW-LSZH (what I did a lot before the reinstallation).

I saw some performance issues in the past too but now its really heavy. 

 

I am available for any remote session or whatever you need :)

@turbofandude

Share this post


Link to post
Share on other sites
  • -1
On ‎11‎/‎16‎/‎2017 at 9:48 AM, vfrsouthbound said:

Since using P3DV4 i have terrible display frame rate mostly when departing and arriving. The Displays seem to lag very bad like between 2-5 fps on the displays. But the aircraft will be running just fine 20-30 FPS. I tried locking my frames at 30 and that seems to help a little. Also once I get near cruise it seems to smooth out a bit more. And clicking outside P3D, like multi-tasking, I can see the displays improve. Any ideas as to why this is happening? 

Same here. Display performance is horrible. The plane is getting 30-40 fps but the displays (PFD, etc) are extremely slow. 

I've tried both with hardware rendering on and off. No difference.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now