Mission.Control

CTD on Aircraft Selection in P3D 4.1

Recommended Posts

Hello! P3D crashes when I select the 717 from the menu.

A few other things:

  1. After it finished installing, I ran it once and it crashed on selection.
  2. After restarting my computer, it crashed and then again a second time.
  3. It's never successfully loaded, just crashed on all attempts.
  4. There's no TFDI crash log in my root P3D folder.
  5. There's no Event Viewer log either...

 

Share this post


Link to post
Share on other sites
16 hours ago, Mission.Control said:

Hello! P3D crashes when I select the 717 from the menu.

A few other things:

  1. After it finished installing, I ran it once and it crashed on selection.
  2. After restarting my computer, it crashed and then again a second time.
  3. It's never successfully loaded, just crashed on all attempts.
  4. There's no TFDI crash log in my root P3D folder.
  5. There's no Event Viewer log either...

 

Try this, load up in the F22 first, then load the 717.

Share this post


Link to post
Share on other sites
1 hour ago, gamesyns said:

Try this, load up in the F22 first, then load the 717.

Had already tried that a few times, no dice on any attempt. The model loads fine in the previewer, but once I click ok, it freezes and then crashes.

But I did try that once more last night and twice today and was able to find three different Event Viewer entries: 

Faulting application name: Prepar3D.exe, version: 4.1.7.22841, time stamp: 0x59d67e95
Faulting module name: api.dll, version: 4.1.7.22841, time stamp: 0x59d67f36
Exception code: 0xc0000005
Fault offset: 0x0000000000015601
Faulting process id: 0x8f0
Faulting application start time: 0x01d3f0aaf1fd45b5
Faulting application path: R:\P3D_v4\Prepar3D.exe
Faulting module path: R:\P3D_v4\api.dll
Report Id: 9e7de79c-69e3-4f7b-87b9-371b16de6c8b
Faulting package full name: 
Faulting package-relative application ID: 

 

Faulting application name: Prepar3D.exe, version: 4.1.7.22841, time stamp: 0x59d67e95
Faulting module name: ntdll.dll, version: 10.0.17134.1, time stamp: 0x207580e2
Exception code: 0xc0000005
Fault offset: 0x000000000005a8fb
Faulting process id: 0x3518
Faulting application start time: 0x01d3f132427ba7bb
Faulting application path: R:\P3D_v4\Prepar3D.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 2e500649-4068-4f8d-92e6-9c5680e06fbe
Faulting package full name: 
Faulting package-relative application ID:

 

Faulting application name: Prepar3D.exe, version: 4.1.7.22841, time stamp: 0x59d67e95
Faulting module name: atc.dll, version: 4.1.7.22841, time stamp: 0x59d67e94
Exception code: 0xc0000005
Fault offset: 0x000000000002a7f5
Faulting process id: 0x2fd4
Faulting application start time: 0x01d3f132ff16c01c
Faulting application path: R:\P3D_v4\Prepar3D.exe
Faulting module path: R:\P3D_v4\atc.dll
Report Id: dc73bc4d-6740-4400-839b-5d9577cb5b8d
Faulting package full name: 
Faulting package-relative application ID: 

 

Share this post


Link to post
Share on other sites
Posted (edited)

@gamesyns  I'm going to move forward with an uninstall, re-download, and re-install. Do you know where the Addon Manager stores the previous download so I can go delete it and re-download it?

Edit: After the uninstall, the Manager says to click download but it appears to use the previously downloaded package instead of actually getting a fresh copy.

Edited by Mission.Control

Share this post


Link to post
Share on other sites
44 minutes ago, Mission.Control said:

After the reinstall, it's still CTD'ing in the same way. No Event Viewer entry either...

@turbofandude

Share this post


Link to post
Share on other sites

I'm just going to update P3D to 4.2 since that's going to be the minimum requirement for most addons going forward.

Will come back if there are any issues....

Share this post


Link to post
Share on other sites

Nope, still crashing. Latest Event Viewer log:

Faulting application name: Prepar3D.exe, version: 4.2.21.24048, time stamp: 0x5a7c832c
Faulting module name: api.dll, version: 4.2.21.24048, time stamp: 0x5a7c83e1
Exception code: 0xc0000005
Fault offset: 0x0000000000015611
Faulting process id: 0x3e74
Faulting application start time: 0x01d3f1563237f37a
Faulting application path: R:\P3D_v4\Prepar3D.exe
Faulting module path: R:\P3D_v4\api.dll
Report Id: 80fd5b4c-7bd5-49a4-956b-ee6ac57a43e8
Faulting package full name: 
Faulting package-relative application ID: 

Loaded up the default P3D flight with the F-22 first and no dice.

Share this post


Link to post
Share on other sites

Please try removing all instances of Microsoft Access from your computer and then reinstalling the aircraft.

Share this post


Link to post
Share on other sites

@turbofandude Couldn't help but scratch my head when you said to uninstall Access as I've never made mention of it, or actually seen it on my machine, but sure enough it was there (both English and Spanish apparently!) and I certainly don't remember installing it either.... 🤔 

...but it worked!! 

https://imgur.com/a/EXPURVM

For anyone else with this issue, here's what I did:

  1. Uninstalled the 717.
  2. Uninstalled MS Access.
  3. Restarted my machine.
  4. Reinstalled the 717 using TFDI Addon Manager with Admin privileges. Don't really know if Admin is needed but I don't think it hurt.
  5. Started P3D and it loaded just fine.

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

And what should I do, if I need Access for my job?

I guess I´m not allowed to use your software then? (which would be a pity)...

Edited by fsinmotion

Share this post


Link to post
Share on other sites
8 hours ago, fsinmotion said:

And what should I do, if I need Access for my job?

I guess I´m not allowed to use your software then? (which would be a pity)...

Can you install a 64 bit version of Access?

Share this post


Link to post
Share on other sites
On 6/5/2018 at 4:48 PM, fsinmotion said:

And what should I do, if I need Access for my job?

I guess I´m not allowed to use your software then? (which would be a pity)...

Hi

Have the same problem here.

By me it is a big deal because I have Office 365 which has all app and no way to remove only Microsoft Access.

Regards, David

Share this post


Link to post
Share on other sites
On 6/6/2018 at 12:41 AM, gamesyns said:

Can you install a 64 bit version of Access?

Hi!

As mentionned here (sorry for duplicates), I also experiment the same problem

Access is already on 64b

image.png.07bef700ba302ac07ddbe1b3288102a3.png

I cannot really uninstall Access or Office 365 because... well... I would like to use it, as well as 717 (not necessarilly at the same time, but still xD)

Another solution would be greatly appreciated 

Best regards

Benoît

 

Share this post


Link to post
Share on other sites
10 hours ago, Vagner_Benoit said:

Hi!

As mentionned here (sorry for duplicates), I also experiment the same problem

Access is already on 64b

image.png.07bef700ba302ac07ddbe1b3288102a3.png

I cannot really uninstall Access or Office 365 because... well... I would like to use it, as well as 717 (not necessarilly at the same time, but still xD)

Another solution would be greatly appreciated 

Best regards

Benoît

 

By me it also will not work even when I installed the Access 64 bit and removed the 32 bit.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.