• 0
orbmis

717 AutoRudder Issues

Question

Hello,

I've noticed some questionable results pertaining to the autorudder in the v1.1 717. Before loading the 717, I check the P3D in-sim autorudder, and it is checked. Upon loading the 717, the in-sim setting immediately goes unchecked. Upon checking the Tablet, I have enable autorudder checked/enabled. Going back & rechecking in-sim, it still indicates unchecked. Upon exiting P3D, and restarting , the in-sim autorudder is still unchecked.

Strange,,, starting off, in-sim has AR enabled, the 717 tablet has it enabled, but yet it is not active. And then upon exiting, the in-sim setting is now unchecked. There was a previous thread about this issue, but it was closed without any resolution being provided.

Is TFDi overriding something, and then neglecting to turn the autorudder back on? Just somewhat frustrating, as I never really seem to be certain if the AR is enabled or not. I don't recall this issue in v1.0 Opt-in Beta; so it seems like it was introduced in v1.1

Hope you can shed some light on this, and hopefully a resolution.

Thanks,

Mike

 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1
2 hours ago, turbofandude said:

@GerdD Our code implements a custom form of autorudder, hence we disable the default one while the aircraft is in use. We put the in-sim autorudder setting back to whatever it was when you unload the aircraft. The indication on the tablet is the one you would want to check to see if it's in use on our aircraft.

Would also appreciate if You could explain what means "unloading the aircraft".

This Autorudder issue is certainly one of the minor problems. However, I am afraid you´ll get no rid of it,

cause it´s definitely not ok if software is changing P3D settings.

Share this post


Link to post
Share on other sites
  • 0
On ‎8‎/‎6‎/‎2018 at 12:02 AM, orbmis said:

Hello,

I've noticed some questionable results pertaining to the autorudder in the v1.1 717. Before loading the 717, I check the P3D in-sim autorudder, and it is checked. Upon loading the 717, the in-sim setting immediately goes unchecked. Upon checking the Tablet, I have enable autorudder checked/enabled. Going back & rechecking in-sim, it still indicates unchecked. Upon exiting P3D, and restarting , the in-sim autorudder is still unchecked.

Strange,,, starting off, in-sim has AR enabled, the 717 tablet has it enabled, but yet it is not active. And then upon exiting, the in-sim setting is now unchecked. There was a previous thread about this issue, but it was closed without any resolution being provided.

Is TFDi overriding something, and then neglecting to turn the autorudder back on? Just somewhat frustrating, as I never really seem to be certain if the AR is enabled or not. I don't recall this issue in v1.0 Opt-in Beta; so it seems like it was introduced in v1.1

Hope you can shed some light on this, and hopefully a resolution.

Thanks,

Mike

 

Have already complained about this several weeks ago during the beta phase.

Got answer that autorudder check in P3D get´s resetted if at end of flight a default aircraft

is reloaded. No further response on argument that nobody is really doing this at end of flight.

 

 

Edited by GerdD

Share this post


Link to post
Share on other sites
  • 0

@GerdD Our code implements a custom form of autorudder, hence we disable the default one while the aircraft is in use. We put the in-sim autorudder setting back to whatever it was when you unload the aircraft. The indication on the tablet is the one you would want to check to see if it's in use on our aircraft.

Share this post


Link to post
Share on other sites
  • 0
20 minutes ago, turbofandude said:

@GerdD Our code implements a custom form of autorudder, hence we disable the default one while the aircraft is in use. We put the in-sim autorudder setting back to whatever it was when you unload the aircraft. The indication on the tablet is the one you would want to check to see if it's in use on our aircraft.

 

Hi Collin,

While returning the in-sim autorudder setting to its previous state, may be your intent, I simply do not see that happening on my system....

===================

I begin by starting P3D, and make note of the autorudder =checked;

I load TFDi 717, and fly for a bit.

I close P3D.

Reopen P3D , and make note of autorudder = unchecked.

=====================

One thing I do notice is you use the words ‘unload the aircraft’. Are you referring to a particular method to exit the 717’s flight? Or, does closing P3D = unload the aircraft.

i certainly appreciate the fine aircraft your group has developed, so this is presented more as a bug report, rather than a criticism. I do award TFDi for their solid customer support efforts.

Mike

 

 

 

Share this post


Link to post
Share on other sites
  • 0

@orbmis I've figured it out. We actually removed the custom autorudder implementation, as it was deemed unnecessary (the default setting controls ours, now). That also resolves it adjusting the default autorudder setting.

Share this post


Link to post
Share on other sites
  • -1

We agree - it only "changes" it while the aircraft is in use. It puts it back as you had it when you shut down the sim or change to a different plane (or, at least, it should be).

Share this post


Link to post
Share on other sites
  • -1
5 hours ago, turbofandude said:

We agree - it only "changes" it while the aircraft is in use. It puts it back as you had it when you shut down the sim or change to a different plane (or, at least, it should be).

and what´s gonna happen if flight ends up with a crash?

Share this post


Link to post
Share on other sites
  • -1
On 8/8/2018 at 5:16 PM, GerdD said:

and what´s gonna happen if flight ends up with a crash?

I'm not sure I follow you. If you need autorudder, enable it in the tablet.

Share this post


Link to post
Share on other sites
  • -1
10 hours ago, turbofandude said:

I'm not sure I follow you. If you need autorudder, enable it in the tablet.

Collin, the issue  is still resetting the Autorudder check in P3D settings after

flight with the 717. So how do you put it back if the flight ends up with a crash?

Just to think about....

Edited by GerdD

Share this post


Link to post
Share on other sites
  • -1
On 8/8/2018 at 11:38 AM, turbofandude said:

@orbmis Ah! There lies the issue. Yes, it's supposed to be restoring it to your setting anytime you're not flying the aircraft. I will take another look at it.

Hi Collin,

Any update on your findings on this issue? It managed to catch me again, as a new session of P3D started with AutoRudder turned off/ left off by TFDi 717.

thanks,

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now