• 0
Sign in to follow this  
BBB

No TruGlass

Question

I had truglass disabled until now because old video card. Just installed a GTX1070ti and updated to P3D 4.4. and updated TFDI. There is no entry to enable/disable in addons. 

reinstalled the 717 and truglass and reallight installers do something but still nothing. The "Disable Transparent Surfaces" option is unchecked. The dll is installed in the gauges folder.

is there supposed to be an entry in dll.xml?

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

I'm having the same problem. I've been using TrueGlass and RealLight before this update, but after 1.1.1.0 and 1.1.1.1 TrueGlass is gone. RealLight apparently works tho.

Share this post


Link to post
Share on other sites
  • 0

Am i posting this question in the wrong place? I also saw a streamer on twitch last night whos trueglass stopped working also.

Share this post


Link to post
Share on other sites
  • 0
On 12/28/2018 at 10:06 PM, dimkzr said:

I'm having the same problem. I've been using TrueGlass and RealLight before this update, but after 1.1.1.0 and 1.1.1.1 TrueGlass is gone. RealLight apparently works tho.

Problem fixed with a clean reinstall of P3Dv4.4 and the 717. So at least it safe to say that TrueGlass isn't broken in the 1.1.1.1

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I have the same issue aswell.
Trueglass is working neither in the B717 nor Maddog X.

Trueglass.dll is found in gauges folder
re-installed B717 as admin several times. unchecked "disable transaprent surfaces" in TFDI Addon manager.

However no entry was made in add-on cfg, so had to manually add it  via Lorby organizer. (pointed to Trueglass xml found in Simobjects/airplanes/tfdi B717/Trueglass)
I'm ready to give up... :)

 

EDIT: also installed latest version via stand alone installer that was provided by maddog X, found in Documents\Prepar3D v4 Add-ons\MaddogX:
Still does not work.

Edited by SAS443

Share this post


Link to post
Share on other sites
  • 0

I am having the same exact issue as well. I just noticed this yesterday. I have tried everything that everyone else has tried and nothing. Is there any new ideas to get it working?

 

Scott Erb

Share this post


Link to post
Share on other sites
  • 0

I posted this in my support ticket. 

"I'm happy to inform you that I have solved it.
since I run P3D 4.3, your installers for real light and true glass will look online for latest versions (which seems incompatible with P3D 4.3)
Solution is to go OFFLINE before running the installers, then the local copy of true glass and real light will be installed, and they play nice with P3D 4.3"

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 1/7/2019 at 2:08 AM, SAS443 said:

Solution is to go OFFLINE before running the installers

Did not work for me in p3dv4.4. when i updated the 717 they update the trueglass dll. Where are the older copys stored?

Edited by BBB

Share this post


Link to post
Share on other sites
  • 0

Just received latest tfdi update now everything is working THANK YOU!!!!

Share this post


Link to post
Share on other sites
  • 0

Yes! That did the trick for me as well. I am curious... was this a system wide update from TFDi or was it just for us with 4.3 having issues? Thank you!

 

-Scott Erb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this