• 0
howes6666

WX Radar not working

Question

I recently noticed that when flying through severe storms/any kind of precipitation, the WXR isn't showing anything on the main flight display. Even when i play with tilt etc it is just blank. When I bring up the Rex gauge window via the menu (Since I have it for other aircraft), this is showing that there is precipitation being picked up so it must have something to do with the aircraft itself. I used active sky and default weathers in P3D to see if it would make a difference but doesn't seem to. Any Ideas? 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Update 2:

I have fixed the WXR and the build can be found on our Discord; please react to the emoji to give yourself the v5 Beta Tester role in the #assign-roles and you can find the beta 717.dll to run. We have yet to push out an official update, pending a few other changes. 

Share this post


Link to post
Share on other sites
  • 0

Update:

Confirmed - the AS API has changed, thus, making the WXR inop. 

I have worked on the updated code and just sent out a build to our internal team earlier today. Once we have verified everything works, we will have an official update out soon. 

Note -- the Milviz REX weather radar, for anyone using this, is also not working in v5. Provided their API is unchanged, the 717's radar (if using the Milviz REX radar) will resume working when they push out an update. 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, RogueShadow said:

Update 2:

I have fixed the WXR and the build can be found on our Discord; please react to the emoji to give yourself the v5 Beta Tester role in the #assign-roles and you can find the beta 717.dll to run. We have yet to push out an official update, pending a few other changes. 

Hi Rogue

I'm still on P3dV4, but upgraded to the new activesky P3d (with their new weather radar api). I don't plan on upgrading to P3dV5. Do you think your v5 beta will still run under V4 or will it break? I miss flying with weather radar!

Cheers

Marc

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, marc0_uk said:

Hi Rogue

I'm still on P3dV4, but upgraded to the new activesky P3d (with their new weather radar api). I don't plan on upgrading to P3dV5. Do you think your v5 beta will still run under V4 or will it break? I miss flying with weather radar!

Cheers

Marc

Hi Marc,

The one I've uploaded on Discord will break the v4 wx radar. If you are still on v4, no update is required.

(note - in the official release, both v4 and v5 wx radars will be functional. this is just for the beta)

Cheers,

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, RogueShadow said:

Hi Marc,

The one I've uploaded on Discord will break the v4 wx radar. If you are still on v4, no update is required.

(note - in the official release, both v4 and v5 wx radars will be functional. this is just for the beta)

Cheers,

Hi Rogue

Just want to clarify - I'm using the latest version of Activesky P3d (not "ActiveSky for P3Dv4" but Activesky P3D"). The wx radar doesn't work in the 717.

I wasnt 'sure if you were aware, or thought it was a thing that only affects V5, but the TFDi 717 in V4 will definitely need an update too.

Cheers

Marc

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, marc0_uk said:

Hi Rogue

Just want to clarify - I'm using the latest version of Activesky P3d (not "ActiveSky for P3Dv4" but Activesky P3D"). The wx radar doesn't work in the 717.

I wasnt 'sure if you were aware, or thought it was a thing that only affects V5, but the TFDi 717 in V4 will definitely need an update too.

Cheers

Marc

Can you check if you have either of the following, or both:

  • as_connect_64.dll
  • as_connect_v5.dll

These are the modules the aircraft uses for the wx radar API. 

Share this post


Link to post
Share on other sites
  • 0
On 5/26/2020 at 2:17 AM, RogueShadow said:

Can you check if you have either of the following, or both:

  • as_connect_64.dll
  • as_connect_v5.dll

These are the modules the aircraft uses for the wx radar API. 

ASPD3 beta can be used in P3DV4.5HF3, as well as P3DV5. For those users who have the 717 installed in V4.5HF3 and using the new ASPD3 beta, the 717.dll would have to reference as_connect_V5.dll for radar to work, just as it does in the V5 beta version of the aircraft.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, JRBarrett said:

ASPD3 beta can be used in P3DV4.5HF3, as well as P3DV5. For those users who have the 717 installed in V4.5HF3 and using the new ASPD3 beta, the 717.dll would have to reference as_connect_V5.dll for radar to work, just as it does in the V5 beta version of the aircraft.

Thank you for letting me know; I will modify the code for this logic. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.