Jump to content

smartCATS.exe The application was unable to start correctly (0x000007b)


Pat738
 Share

Recommended Posts

I've been using smartCARS in our VA (joinava.org) for years. I've moved to a new server computer AMD 5950/W10. I've gone thru the tFDi suggested 

1. W10

2. .NET FRAMEWORK 4.8

3. XPUIPC

4.VISUAL c++ 2010 (X86)

5. DIRECT x jUNE 2010 REDIST.

 

i unistalled msvcr100.dll off of SYS32 & WOW64. ( just like forum post , Fabio Almieida suggested.).

I'm at a loss what to try next. 

Thanks, 

Pat738

 

 

INSTALLATION:
7/16/2022 5:18 PM,  initialzed
Microsoft Windows NT 6.2.9200.0 (x64)
reg_exists(): returning false, OpenSubKey returned null for the child


RUN:
smartCATS.exe - Application Error
The application was unable to start correctly (0x000007b)
Click OK to close the application.

 

UNINSTALL:
7/16/2022 5:19 PM,  initialzed
Microsoft Windows NT 6.2.9200.0 (x64)
an exception occured in bkgwkruninstall_DoWork(...): System.ArgumentException: Cannot delete a subkey tree because the subkey does not exist.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey, Boolean throwOnMissingSubKey)
   at tfdi_installer.mainform.bkgwkruninstall_DoWork(Object sender, DoWorkEventArgs e)
an exception occured in bkgwkruninstall_DoWork(...): System.NullReferenceException: Object reference not set to an instance of an object.
   at tfdi_installer.mainform.bkgwkruninstall_DoWork(Object sender, DoWorkEventArgs e)
an exception occured in bkgwkruninstall_DoWork(...): System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Program Files (x86)\smartCARS\568\en-US\logs'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)
   at tfdi_installer.mainform.bkgwkruninstall_DoWork(Object sender, DoWorkEventArgs e)
 

tfdi_installer.zip

Link to comment
Share on other sites

  • 2 weeks later...

The problem has been resolved with help of DISCORD TFDI Support. 
the   msvcr100.dll  and msvcp100.dll in Window SysWOW folder did not correct key update when reinstalling the 2010 C++redistributable. Everything is working great now. Thanks for following up on this. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.