schmeichel75

1.0.4 still very bad performance

Recommended Posts

Hi there!

I decided, to reinstall the addon, since the most recent version seem to run just fine for some users. On my machine, the displays may lag a bit less, but the whole sim is still very low on fps and stuttering quite heavily. It´s still unflyable. 

Edited by schmeichel75

Share this post


Link to post
Share on other sites

Hi Schmeical 

 

Sorry about this, but if your still trying to get a good performance on your i3 machine then you are going to struggle. I know it's frustrating to be told that but our flight sims are always cpu intensive, even P3D with all the work that has been done to shed some of the load onto the graphics card. Upgrades can be an expensive business and God knows I've spent far more than I should on flight sim hardware and software over the years, but I fear there may be no other option in this case.

take care

Neil

Share this post


Link to post
Share on other sites

hmm look here ... I have a similar PC ... except for VGA .. and i dont have problem 

 

Edited by FeRo

Share this post


Link to post
Share on other sites
1 minute ago, FeRo said:

hmm look here ... I have a similar PC .. and i dont have problem 

 

The graphics card seems to be the problem. I´ll upgrade to an 1070 8GB anytime soon.

Share this post


Link to post
Share on other sites
Just now, FeRo said:

good VGA is not all ... very important is CPU with high frequency on core ..

Sure, but all my other addons perform quite nicely and with smooth fps on my system.

Share this post


Link to post
Share on other sites

unfortunately .. FSX/P3D dont have good engine .. yes LM significantly improve P3D but they are not a magicians.. we can have best PC but .. People with .. AMD or old HW what to say unfortunately. who has a good PC must fight for every frame.

neither on
 8 core intel with GTX 1080 or pascal don't get stable 60FPS
Edited by FeRo

Share this post


Link to post
Share on other sites

It's probably because your limited 2gb of vram is being stuffed quickly and your PC is having to rely on swapping when the vram gets full.

Share this post


Link to post
Share on other sites

Unlike other addons, the 717 (and many products at Milviz) have shifted a lot of their internal processing from the CPU to the GPU so having a decent video card will improve things.

Share this post


Link to post
Share on other sites

Yes, that might be the problem here. Although, AS Airbus, NGX, Q400, etc. just work fine on my system. 

For the time being, I've uninstalled the 717. 

Share this post


Link to post
Share on other sites

Hi, exactly the same config (except 4go of vram), and same problems for me: low fps (15-20) and a lot of stutters. Other planes work perfectly with 30+ limited fps and no stutters (Majestic q400, AS A320 & CRJ700 beta, pmdg 737). 

Any idea ?

EDIT: I've tried with the CGU display render option ON and OFF, this didn't change anything. I'll try to monitor the ram, vram, gpu and cpu uses next time.

Edited by foobar

Share this post


Link to post
Share on other sites

well the problem is stil there it seems, it improves a bit but only push the problem a bit in time but does not solve it completely from what I have seen over time..

Edited by KAPTEJNLN_

Share this post


Link to post
Share on other sites

for me is better option HW rendering off..

 

BTW  turn off coopilot screen = +5-6 FPS

Share this post


Link to post
Share on other sites
1 hour ago, Flyschool said:

Did you check "Allow hardware rendering" box hear ?

337cb85d44.jpg

I tried both. With hw rendering off, the CPU load is over 95% all the time, and the stuttering gets even worse. 

With it on, the displays lag very badly and the FPS fluctuate a lot. Both states are unflyable for me. 

Edited by schmeichel75

Share this post


Link to post
Share on other sites

As someone who has been struggling with high fps fluctuations, I've managed to reach a more steady point by doing the following:

 

1. new installation of FSX

2. No add on, except for Terra Emergence textures

3.Affinity mask tweak

4. high mem tweak

5. Buffer pools tweak

6. Graphic settings : Ultra High

7. Water settings: high 2x

8. No NV Inspector

9. AI 20%

System: i5-2500k @4.4 8ghz Ram  gtx 1060 latest drivers   Hard Drive

 

I am able to start at LInate airport with steady 30 fps.  The stuttering starts to happen in the turns. The panel is steady, but the scenery appears to stutter on a regular basis.

 

If it helps the developers, I remember when Just Flight released its DC8, an aircraft that's fairly light compared to the TFDI model, but in turns there was a lot of stuttering.

It was concluded that some of the instruments, specifically the HDI, was the culprit.

tony

Share this post


Link to post
Share on other sites

Hello, just tried to remove the fps limitation so I got 16-50 fps with hw rendering off. The fps drop happens every 3-4 seconds @ parking when displays are ON.

GPU use (GTX 670): 41%
VRAM use (4Gb): 66%
CPU use (i5@4.2GHz): 91-100%
RAM use (16Gb): 43%

It's look like a unwell coded loop.

Share this post


Link to post
Share on other sites
26 minutes ago, FeRo said:

BTW CPU full load is normal situation .. 

No, not for me.

With the Aerosoft Airbus and the NGX, I have between 50-85% CPU load in P3Dv3, depending on the the situation, the scenery, stage of flight, etc. And that is with web browser, ACARS, FSC9, AS16, ASCA and IVAP running in the background.

Edited by schmeichel75

Share this post


Link to post
Share on other sites
9 minutes ago, foobar said:

Hum, when I turn ON the hw rendering the CPU use drop to 80% but the GPU use grow to 100%.

 

That´s it! And that´s why I hope that performance will get better with my new card (1070 8GB).

With my old 2GB 670, I get better fps with HW Rendering on, but displays get laggy and the fps fluctuate heavily.

Share this post


Link to post
Share on other sites

Yes but 40% of a GTX670 gpu in order to display some screens... there is definitively a probleme with thier code :)

(and stutters are still there)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now